Presentación

Easy Letras TRV(aplicación para la gestión de Letras de Cambio)
Ir al índice general de la ayuda

Web: www.trevenque.es

Correo electrónico: treven@trevenque.es


Indice de la ayuda

Easy Letras TRV Easy Letras TRV es una aplicación Windows desarrollada por Trevenque S.I que pretende automatizar la gestión e impresión de letras de cambio. La facilidad de uso y la capacidad de personalizar el formato de impresión de las letras para distintos tipos de impresoras son las características más destacables de este producto.
Capítulos tratados en la ayuda
 | Maestros
 | Letras de Cambio
 | Ventanas
 | Ayuda


Mantenimientos Maestros
 | La información necesaria para gestionar las letras de cambio se encuentra almacenada en una base de datos. Los mantenimientos son ventanas de entrada de datos en dónde se introducen está información básica.
 |  | Empresas Libradoras
 |  | Bancos y Sucursales
 |  | Clientes
 |  | Tipos de Monedas


Opciones generales de los mantenimientos

Operaciones generales en los mantenimientos

Podemos realizar las siguientes operaciones:

Añadir un nuevo registro.
Eliminar el registro seleccionado.
Recuperar los registros de la base de datos. Si se ha producido algún cambio se pedirá confirmación.
Entrar en la ventana de consulta.
Guarda los cambios realizados por el usuario en la base de datos.

Cancela las últimas modificaciones realizadas sobre algún registro.
Podemos realizar una importación masiva de datos de las diferentes entidades a partir de ficheros procedentes de otras aplicaciones.
Cierra la ventana. Si ha habido cambios pedirá confirmación para guardarlos.


Empresas Libradoras

El mantenimiento de empresas le permitirá almacenar los datos referentes al librador de la letra de cambio. Sólo es necesario introducir el nombre de la empresa. El domicilio se puede omitir lo cual le obligaría a poner el sello de la empresa encima de los datos del librador una vez que los efectos han sido impresos. Sin embargo, se ha incluido el campo C.I.F. para facilitar la búsqueda de las mismas en el buscador incorporado...

Desde esta ventana puede hacer las operaciones típicas del registro de información en una base de datos: Añadir y eliminar empresas, recuperar y consultar las empresas que previamente han sido almacenadas, y actualizar los cambios realizados en la base de datos.

Ver Operaciones Generales con Mantenimientos.


Bancos y Sucursales

El mantenimiento de Bancos y Sucursales le permitirá registrar la información necesaria para posteriormente poder asignarle a cada cliente un domicilio de pago para la generación de letras. A cada banco se le asociará una lista de sucursales de interés para la generación de letras de cambio.

Las operaciones de mantenimiento (añadir, eliminar, actualizar, etc ...) afectan al visor de datos sobre el que estemos situado, es decir, si queremos añadir un nuevo banco deberemos situarnos sobre el visor de bancos y después pulsar el botón "Añadir". Una vez que los datos introducidos sean correctos el usuario deberá pulsar el botón "Actualizar".

De igual forma si deseamos visualizar los bancos que tenemos almacenados debemos pulsar el botón "Recuperar" para obtenerlos todos o bien realizar una búsqueda selectiva pulsando el botón "Consultar". Con las teclas [AV PAG] y [RE PAG] nos podremos desplazar para visualizar bancos y con las fechas direccionales arriba [UP] y abajo [DOWN] cambiaremos de sucursal.

Además, en la parte superior encontramos un pequeño buscador que nos permitirá realizar búsquedas tanto por códigos bancarios como por nombre de los mismos... Para ello, sólo deberemos introducir la palabra a buscar, indicar sobre que campo vamos a realizar la búsqueda y pulsar el botón "buscar".

Ver Operaciones Generales con Mantenimientos.


Clientes

El mantenimiento de clientes le permite introducir y almacenar información referente al librado, como son sus datos personales y el domicilio de pago.

Todos los campos que aparecen en la ficha son requeridos incluyendo el campo NIF/CIF que se utiliza para agilizar las búsquedas de clientes en el buscador incorporado en la misma página... Con él, podrá acceder rápidamente a los datos de un determinado cliente, ya sea buscando por Nombre o por NIF/CIF.

Tras introducir los datos bancarios del librado, el dígito de control de la cuenta corriente se calcula automáticamente indicándole si los datos bancarios proporcionados son correctos. De todas fomas el dígito de control puede ser modificado aunque no sea el correcto.

En caso de no conocer el código de la Entidad o de la Oficina, podrá acceder a una ventana de búsqueda pulsando los iconos de lupa que existen junto a esos campos.

Ver Operaciones Generales con Mantenimientos.


Tipos de Moneda

Tipos de Monedas

La ventana de mantenimiento de monedas le permitirá configurarse distintos tipos de monedas con los que trabajará la aplicación.

El significado de los campos del mantenimiento de monedas es el siguiente :

Código | Cadena alfanumérica de tres caracteres para identificar el tipo de moneda.
Descripción | Descripción del tipo de moneda. Este campo se utiliza en la generación de letras de cambio para especificar el campo "MONEDA".
Género | El género se utiliza para generar el importe en letra de la letra adecuadamente.
Símbolo | Símbolo asociado a la moneda para su representación visual.
¿ Decimales ? | Indica si el tipo de moneda aparecerá con decimales o en valores enteros.

Ver Operaciones Generales con Mantenimientos.


Ventana de Importación de Datos

La ventana de importación es utilizada, salvo en el caso de Letras de Cambio, para la importación a la Base de Datos de Entidades procedentes de un fichero de texto con un determinado formato.

Una vez Abierto el Fichero, se incorporarán los datos obtenidos del fichero en una tabla con los diferentes campos.

A partir de aquí podrán seleccionarse todos los registros, sólo algunos, y una vez finalizada la selección, pulsaremos sobre el botón de importación para incorporar los datos...

En la tabla de registros podremos ver todos los datos que se han incorporado procedentes del fichero, pero no se importarán a la base de datos hasta pulsar el botón de importación.

En la zona inferior se nos dará la información del proceso de importación, indicando los registros erróneos.

Controles de interés de la ventana importación
 | Esté botón realiza la selección de todos los registros recuperados del fichero de importación.
 | Al contrario que el anterior, elimina la selección que tuviéramos anteriormente.
 | Al pulsar se abrirá la ventana de selección de ficheros, para que podamos seleccionar el fichero del que vamos a importar los datos.
 | Al pulsar este botón comenzará el proceso de importación de los registros que hayamos seleccionado en la ventana.
 | Al pulsar se abrirá este fichero de ayuda.
 | Saldremos de la Ventana de Importación.


Easy Letras TRV

Letras de Cambio
 | Una de las principales novedades de la aplicación es la facilidad de gestión de los efectos y la capacidad de definirse formatos de impresión personalizados por el usuario para distintas impresoras.
 |  | Generación de Letras
 |  | Formatos de Impresión
 |  | Exportación de Datos a EXCEL
 |  | Opciones de Configuración


Generacion de Letras

Generación de Letras de Cambio

La ventana de generación de letras de cambio es uno de los módulos principales de la aplicación y el más utilizado por el usuario.

Desde esta ventana se especifican todos los datos necesarios para generar e imprimir letras de cambio.

Seleccione en el gráfico aquella zona de la ventana sobre la que desee tener información.

Datos comunes para la generación de las letras
Cliente | Debe seleccionar el cliente que actuará como LIBRADO. Previamente, el cliente debe haber sido introducido en la ventana de Mantenimientos de Clientes. La mayor parte de la información de la letra se obtiene de los datos del cliente (información del librado, domicilio de pago y número de cuenta corriente).
Empresa | Debe seleccionar la empresa que actuará como LIBRADOR de la/s letra/s. Previamente, debe haber dado de alta la empresa en Mantenimientos de Empresas. De los datos de la empresa se extrae el nombre y domicilio del LIBRADOR. Se puede establecer una empresa (o LIBRADOR) por defecto en Configuración que se mostrará siempre que entre en la ventana de generación de letras.
Lugar de Libramiento | Texto que aparecerá en el apartado "Lugar de Libramiento" de la Letra. Se puede predeterminar en Configuración.
Moneda | Los datos del tipo de moneda se utilizan para especificar el apartado "MONEDA", utilizar un formato adecuado para "IMPORTE" y generar el importe en letra del efecto. El tipo de moneda se puede predeterminar en Configuración.
Periodicidad | Periodicidad en meses que se utiliza para generar la fecha de los vencimientos a partir de la fecha del primer vencimiento. Si especifica el último día de un mes, los vencimientos se generaran a final de mes.
Número de Vencimientos | El número de vencimientos determinará el número de letras que deseamos generar.
Fecha Libramiento | Fecha que se utiliza en el apartado "Fecha de Libramiento" de las letras.
Fecha Primer Vencimiento | Fecha de vencimiento de la primera letra que se toma como base para calcular, según la periodicidad indicada, las fechas de vencimiento de las siguientes letras.
Fecha ACEPTO | Fecha para el apartado "Fecha ACEPTO" de la letra. Para establecer la fecha de ACEPTO en las letras generadas pulse el botón situado a la derecha de esta campo.
Importe del Vencimiento | Importe inicial de todos los vencimientos.
Expresado a... | Texto libre que aparecerá en el apartado "expresado a" de la letra.
Cláusulas | Texto libre que aparecerá en el apartado "Cláusulas" de la letra.
Imprimir Domicilio de Pago | Si desmarca esta opción no le aparecerá los datos del domicilio de pago del librado y en su lugar se imprimirá "Abajo Indicada" en el apartado de la letra "Persona o entidad".

Controles de interés de la ventana de generación de letras
Este botón muestra las impresoras instaladas en el administrador de impresión Windows. Seleccione la impresora por la que desea imprimir las letras.

Pulse este botón para imprimir los vencimientos generados. Por defecto se imprimirán todas las letras. Si desea imprimir una en concreto deberá especificarlo marcando la casilla "¿ Imprimir ?".

Si al imprimir letras por la impresora seleccionada, éstas se muestran descuadradas deberá personalizarse un Formato de Impresión adecuado y establecerlo en Configuración.
Si "Vencimientos Manuales" se encuentra activo, el usuario podrá modificar libremente la fecha de vencimiento de las letras, y el hecho de cambiar el número de vencimientos , la fecha del primer vencimiento o el importe general de las letras no afecta a las líneas de vencimientos.
Permite añadir una nueva línea de vencimiento.
Permite insertar una línea de vencimiento justo antes de la línea de vencimiento actual.
Elimina la línea de vencimiento activa.
Se encarga de abrir la Ventana de Importación / Impresión de Letras, la cual le permite realizar la impresión desde un fichero de texto de un gran número de Letras de Cambio.
Permite abandonar la ventana de generación de letras.

Gestión de Líneas de Vencimientos
¿ Imprimir ? | Para realizar una selección de los vencimientos (letras) que desea imprimir seleccione esta columna. Se imprimirán aquellos vencimientos marcados.
¿ + de 6 meses ? | Si la fecha de vencimiento de la letra supera los 180 días naturales a la fecha de libramiento, entonces el timbre de la letra de cambio es diferente. Por este motivo en este campo y con el color rojo se indican que letras verifican la condición anterior.
Fecha ACEPTO | Fecha de ACEPTO de la letra que puede ser modificada para cada vencimiento.
Fecha Vencimiento | Fecha de vencimiento de la letra. Para modificar esta fecha en cada vencimiento seleccione "Gestión Manual".
Importe vencimiento | Importe en dinero del vencimiento.


Formatos de Impresión

Las letras de cambio son documentos oficiales con un formato predefinido. Cuando se utilizan documentos de este tipo, resulta complicado realizar una aplicación de uso general para listar en los diferentes dispositivos de impresión del mercado, pues cada uno puede tener características diferentes en parámetros de impresión como pueden ser la orientación del papel, el tipo de papel que admiten, el espacio que dejan entre los bordes y los márgenes, etc.

La única forma de solventar estos inconvenientes es permitiendo al usuario personalizar el formato de la letra a las características particulares del dispositivo de impresión que vaya ha utilizar. Con esta finalidad se ha desarrollado la ventana de formatos de impresión.

Para conocer como puede personalizar la letra de cambio, sitúese en el gráfico siguiente y pulse en la zona sobre la que desee obtener información.

Formatos de Impresión

Se pueden definir tantos formatos de impresión como se desee. En el gráfico se puede ver el formato general por defecto y otro personalizado para la impresora "HP V". Desde este visor de datos se puede modificar los márgenes y la orientación de impresión.

Sin embargo, el formato predefinido que se distribuye con la aplicación no puede modificarse, sino que se entrega más bien como modelo sobre el que crear otros...

Este botón permite establecer como formato activo el formato de la fila sobre la que se pulsa. Todas las modificaciones de la letra que realicemos a partir de este momento se aplican sobre el formato activo.

Visualiza en el Visor de Formatos la letra con las características de impresión fijadas en la fila.
Añade un nuevo formato y lo pone activo para almacenar las modificaciones en él.
Elimina un formato de impresión junto con toda la información asociada.
Almacena en la base de datos las modificaciones realizadas en el formato.
Cerrará la ventana de formatos de impresión.

Opciones de configuración
 | Después de personalizar el formato de la letra activo debemos comprobar como va ha quedar su impresión. Este botón permite imprimir una letra de prueba cogiendo la configuración activa para comprobar si la ésta se adecua o no al formato oficial de la letra.
 | Mediante esta opción, podremos seleccionar la impresora con la que vamos a configurar el formato de impresión.
 | Es muy importante, después de realizar las modificaciones apropiadas en el formato activo, almacenar estos cambios. Para ello debe pulsar en este botón.

Visor de formatos de letras

El visor de formatos le permite personalizar todos los campos de la letra modificando su posición, altura y anchura. No olvide guardar el formato después de realizar modificaciones de interés sobre él.

Para desplazar un campo pulse sobre él con el botón izquierdo del ratón y arrastre el ratón hasta posicionar el campo en la posición deseada.

Para cambiar las dimensiones de un campo sitúe el ratón en los bordes del mismo y cuando la forma del puntero del ratón sea una fecha pulse el botón izquierdo y arrastrelo hasta redimensionar el campo al tamaño deseado.


Opciones de Configuracion

Opciones de Configuración

La ventana de configuración permite al usuario especificar algunos parámetros por defecto que manejará la aplicación para la generación de las letras de cambio. Los parámetros de configuración son los siguientes:

Lugar de Libramiento | Texto con el lugar de libramiento de las letras por defecto.
Moneda | Tipo de moneda por defecto. Ver Tipos de Monedas.
Empresa | Empresa libradora por defecto. Ver Mantenimiento de Empresas.
Formato de Impresión | Formato de impresión por defecto que se utilizará en la impresión de las letras de cambio. Ver Formatos de Impresión. Por defecto, la aplicación se distribuye con un formato predefinido.


Importación / Impresión de Letras de Cambio

Ventana de Importación / Impresión de Letras de Cambio

Esta ventana es utilizada para la Impresión de Letras a partir de datos procedentes de un fichero de texto con un determinado formato.

Una vez Abierto el Fichero, se incorporarán los datos obtenidos del fichero en una tabla con los diferentes campos.

A partir de aquí podrán seleccionarse todos los registros, sólo algunos, y una vez finalizada la selección, pulsaremos sobre el botón de impresión para la impresión de las letras correspondientes.

Debido a que es un proceso de impresión en papel oficial y de inserción manual, podremos seleccionar el número de Letras que se imprimirá por bloque. Entre cada bloque, el programa realizará una parada en espera de que se le indique que se ha introducido papel.

Además podremos indicarle a la aplicación si queremos que imprima los datos referentes al domicilio de pago para todos los registros que hayamos seleccionado...

En la tabla de registros podremos ver todos los datos que se han incorporado procedentes del fichero, pero no se importarán a la base de datos hasta pulsar el botón de importación.

En la zona inferior se nos dará la información del proceso de impresión, indicando los registros erróneos.

Controles de interés de la ventana importación
 | Esté botón realiza la selección de todos los registros recuperados del fichero de importación.
 | Al contrario que el anterior, elimina la selección que tuviéramos anteriormente.
 | Al pulsar se abrirá la ventana de selección de ficheros, para que podamos seleccionar el fichero del que vamos a importar los datos.
 | Al pulsar este botón comenzará el proceso de impresión de las Letras que hayamos seleciondo en la ventana.
 | Al pulsar este botón se abrirá éste fichero de ayuda.
 | Saldremos de la Ventana de Importación.


Ventana de Exportación a EXCEL

Ventana de Exportación de Datos

La ventana de exportación es utilizada para realizar un volcado de los datos de un Letra de Cambio a un fichero con formato EXCEL de Microsoft.

En esta ventana, sólamente deberemos seleccionar los campos que deseamos exportar al archivo EXCEL y pulsar sobre el botón "exportar". La aplicación nos solicitará un nombre para el fichero a exportar...

Mediante la pulsación sobre el botón "Guardar como Predeterminado" grabaremos los valores seleccionados en la configuración de la Aplicación, y de este modo, la próxima vez que se realice una exportación, ya se encontrarán marcados los campos deseados.

Aquí deberán seleccionarse los campos deseados para incluir en la Exportación.

En la zona inferior se encuentran los botones de Exportación, Salida y Grabación de Valores por defecto. Además se encuentra el botón de Ayuda, con el que acceder a esta información.


Ventanas

Organización de Ventanas

La opción "Ventanas" del menú principal le permitirá organizar las ventanas de la aplicación dentro del área de trabajo de la ventana principal como desee (vertical, horizontal, etc). Además le permite personalizar las barras de herramientas.


Ayuda

Sistema de Ayuda

Para obtener ayuda en línea sobre cualquier ventana de Easy Letras TRV seleccione la opción del menú principal "Ayuda" y luego seleccione "Temas de Ayuda" o bién pulse la tecla "F1".


Módulo de consulta

Se trata de una pantalla de consulta que permite al usuario diseñar sus propios filtros para la selección de registros asociados a una determinada entidad (clientes, bancos, empresas, etc).

La pantalla está dividida en dos bloques: criterios de selección y registros seleccionados.

Criterios de selección

Pestaña de consulta

En la pestaña de CONSULTA podemos especificar los criterios de la selección de registros que queremos realizar. Elegiremos la columna, el operador y el valor para generar una condición.

Si la expresión que queremos construir tiene más de una condición, con el botón AÑADIR O INSERTAR conseguiremos tener tantas condiciones como necesitemos. Para unir dos o mas condiciones deberemos indicar el operador lógico que las une (Y, O). Con el botón ELIMINAR podremos borrar condiciones.

Pestaña de Ordenar

En la pestaña de ORDENAR podemos especificar los campos por los que queremos ordenar los registros de nuestra consulta. Sólo hay que arrastrar el campo o campos deseados a la columna derecha e indicar si queremos un orden ascendente o descendente para cada uno de ellos.

Pestaña de Sintaxis

En la pestaña de SINTAXIS se nos muestra la instrucción SQL que ejecuta nuestra consulta.

Registros seleccionados

Muestra los registros que cumplan las condiciones que hemos especificado en la parte superior, o todos los registros si no se han especificado condiciones.

Realizar consultaOrdenarGuardarImprimirAceptarCancelarAyudaForma de recuperar registros

CONSULTAR | Realiza la consulta especificada en la pestaña de consulta.
ORDENAR | Muestra una ventana para la selección de los campos por los que queremos ordenar (igual función que la pestaña de ordenar).
GUARDAR | Guarda la consulta en un fichero que puede ser de distintos formatos, entre ellos, en formato de Microsoft© Excel.
IMPRIMIR | Imprime la consulta realizada.
VER REGISTROS | Modo en que se recuperan los registros de la base de datos. Por página indica que los registros se recuperan conforme los vamos necesitando; todos indica que se recuperan todos los registros de la base de datos.
ACEPTAR | Cierra la ventana devolviendo la selección realizada.
CANCELAR | Cierra la ventana sin devolver nada (la selección realizada se pierde).
AYUDA | Muestra esta página de ayuda.


Ficheros de Importación

s Ficheros de Importación
Ficheros para importación de Datos

Los ficheros para la importación de datos deben poseer una estructura determinada para que puedan ser interpretados por la aplicación. Se ha procurado que esta estructura sea sencilla para que se pueda llevar a cabo desde cualquier otra aplicación.

Deberán ser ficheros de texto con los campos separados por tabuladores. Dependiendo de cada entidad, el número de campos y el orden variará según la tabla adjunta.

Empresas | Clientes | Letras
C.I.F. | Nombre de Cliente | Nombre de Cliente
Nombre | Cliente Asociado | Cliente Asociado
Domicilio | Domicilio | Importe
Población | Población | Moneda
Cód. Postal | Cód. Postal | Código Entidad
Provincia | Provincia | Código Sucursal
 | C.I.F./N.I.F. | Código de Control
 | Código Entidad | Número Cuenta
 | Código Oficina | Fecha Libramiento
 | Código de Control | Fecha Vencimiento
 | Número de Cuenta | Fecha Acepto
 | Nombre de la Entidad | Nombre Empresa
 | Nombre de la Oficina | Domicilio Empresa
 | Población de la Oficina | Domicilio Cliente
 |  | Población Cliente
 |  | Cod.Postal Cliente
 |  | Provincia Cliente
 |  | Lugar Libramiento
 |  | Cláusulas
 |  | Expresado a...
 |  | Nombre Entidad Banco
 |  | Nombre Oficina Banco
 |  | Población Oficina
 |  | Importe en Letra...

Los campos que se encuentran en rojo son opcionales, pero deberá dejarse un tabulador de separación de campo en el fichero...

Si en la Importación de Clientes se incluyen los datos correspondientes al Nombre del Banco, Nombre de la Oficina y Población de la Oficina, en caso de que no se encuentren en la Base de Datos de la Aplicación, ésta los incorporará a su Base de Datos de Bancos...

En el caso de la moneda en las Letras de Cambio, la aplicación, en caso de no encontrar ese campo, tomará por defecto la moneda seleccionada por defecto en la Ventana de Opciones de Configuración.


Selección de Entidades Bancarias

Ventana de Selección de Entidades Bancarias

La ventana de Selección de Entidades Bancarias le permite al usuario especificar la búsqueda fácil de Entidades cuyo código no conoce. Colocándose cobre "Criterios de Consulta", según vaya escribiendo, verá como el buscador irá seleccionando aquellas entidades que contengan la cadena que vaya escribiendo, ya sea dentro del campo Código como del Nombre del mismo:


Selección de Sucursales Bancarias

Ventana de Selección de Sucursales Bancarias

La ventana de Selección de Sucursales Bancarias le permite al usuario especificar la búsqueda fácil las Sucursales cuyo código no conoce. Una vez seleccionada la Entidad deseada en el Mantenimiento de Clientes, colocándose cobre "Criterios de Consulta", según vaya escribiendo, verá como el buscador irá seleccionando aquellas oficinas que contengan la cadena que vaya escribiendo, ya sea dentro del campo Código como del Nombre de la misma: